Pages

Thursday, August 13, 2015

Nethunter 2.0 on a Nexus 7 2013 with the TP-Link TL-WN722N

Note: This fix has only been tested on a Nexus 7 2013 (WiFi edition) only. It may or may not work on other Nexus 7 variants (2012, 2013 LTE, etc.). Your mileage may differ from mine. Also note this is for the Kitkat image as the Lollipop images seem to have broken WN722N support. Also take note this is for the KitKat release and NOT for the Lollipop release.

Some of you might be into mobile penetration testing and use a Nexus 7 for that. Some of you may come across the issue that after upgrading to the latest Kali Linux 2.0, or in this case, Nethunter 2.0, on your Nexus 7, connecting an external WiFi adapter such as the cheap but efficient TP-Link TL-WN722N no longer works. Some might suggest trying to fire up aircrack-ng to 'force' the interface up but if you check your dmesg logs, you will not see it connected.

My guess is the kernel does not recognize it. Now running Kali Linux 2.0 on a VM under OSX or Windows 8.1 for that matter, it works flawlessly without a hitch. After all, Nethunter 2.0 is based on Kali Linux 2.0 right? Unfortunately, not on the Nexus 7 at least for me.

The fix? Just open up the Nethunter launcher on your homescreen, select the first option which is to run the terminal window. You should have root access automatically. If this is the first time you do this, SuperSU or Superuser should prompt you for root rights.

Once in the terminal just do a "apt-get install firmware-atheros". This will grab the Atheros chipset modules and allow them to be loaded onto the kernel. For your information, the WN722N runs on the ath9k_htc module. After finished installing this package, unplug your TL-WN722N and replug it and do a "iwconfig" to confirm it lives. If it doesn't, try unplugging and re-plugging it again or reboot your Nexus 7. It should work by now.


4 comments:

Jarrod Levet said...

Good info, thanks.
Unfortunately not working for me. I just wanted to check if you're using the kitkat or lollipop image.

I'm getting the card listed in lsusb, and it looks like its trying to sort the drivers in dmesg output, but no wlan1.

Nickelby said...

Post updated. Should said it was Kitkat :-). Sorry for the long outstanding reply

Niklas Carlberg said...

It isn't working for me

Unknown said...

Works for me, and by the way i am on MM Image with NetHunter 2.0

Works like a charm :)